ExBB Community ExBB Community
 Сайт проекта ExBB Общение объединяет!
Войдите на форум при помощиВойти через loginza
 Чат на форуме      Помощь      Поиск      Пользователи     BanList BanList


 Страниц (2): [1] 2 »   

> Описание: Проблема с %
robert
Отправлено: 4 апреля 2009 — 19:20
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 258
Дата рег-ции: Март 2009  
Репутация: 8




Добрый вечер всем!
Заметил вот такую проблему (с публикацией изображений), ну чтобы не объяснять, привожу пример:


возможно ли как-то исправить, или обойти данную проблему? (удаление таких ссылок не предлагать Подмигивание )
Заранее спасибо всем, за помощь!
 
 
yura3d
Отправлено: 13 апреля 2009 — 17:28
Post Id


Пользователь
ExBB Team
ExBB Developer
ExBB Mods Author


Покинул форум
Сообщений всего: 3394
Дата рег-ции: Февр. 2009  
Откуда: Минск, Беларусь
Репутация: 353




robert пишет:
Добрый вечер всем!
Заметил вот такую проблему (с публикацией изображений), ну чтобы не объяснять, привожу пример:


возможно ли как-то исправить, или обойти данную проблему? (удаление таких ссылок не предлагать Подмигивание )
Заранее спасибо всем, за помощь!

Не знаю почему сразу не увидел эту тему Огорчение
Для исправления описанного недочёта открываем файл include/fm.class.php, находим строку:
CODE:
$string = preg_replace_callback("#\[img\]\s*((http://|www\.)[A-Za-z0-9-_\./\?\&\+\;\,~=]+?)\s*\[/img\]#is",

И заменяем её этой строкой:
CODE:
$string = preg_replace_callback("#\[img\]\s*((http://|www\.)[A-Za-z0-9-_\./\?\%\&\+\;\,~=]+?)\s*\[/img\]#is",

Это всё, что необходимо исправить
 
 
mastersound
Отправлено: 13 апреля 2009 — 18:05
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 604
Дата рег-ции: Март 2009  
Откуда: Ё-бург
Репутация: 23




а не одинаковы ли эти строки?
 
 
robert
Отправлено: 13 апреля 2009 — 18:08
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 258
Дата рег-ции: Март 2009  
Репутация: 8




одинаковы Улыбка ..только /%/ добавляется
 
 
yura3d
Отправлено: 13 апреля 2009 — 18:11
Post Id


Пользователь
ExBB Team
ExBB Developer
ExBB Mods Author


Покинул форум
Сообщений всего: 3394
Дата рег-ции: Февр. 2009  
Откуда: Минск, Беларусь
Репутация: 353




mastersound пишет:
а не одинаковы ли эти строки?

Нет, в последнюю добавлено целых 2 символа (\%). Язычок Полные строки я привёл только лишь с целью, чтобы легче было найти в файле среди множества похожих.
 
 
robert
Отправлено: 13 апреля 2009 — 18:15
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 258
Дата рег-ции: Март 2009  
Репутация: 8




хм, теперь все намано, только превью не отображается Недовольство, огорчение
Вторая картинка..в 1 сообщении на этой страницы.
P.S. Какие то глюки с ID адресом верхнего сообщения на каждой странице темы...ссылка кидает на предыдущую страницу темы...с другими (не верхними) всё вроде нормально.

(Отредактировано автором: 13 апреля 2009 — 18:21)

 
 
yura3d
Отправлено: 13 апреля 2009 — 18:21
Post Id


Пользователь
ExBB Team
ExBB Developer
ExBB Mods Author


Покинул форум
Сообщений всего: 3394
Дата рег-ции: Февр. 2009  
Откуда: Минск, Беларусь
Репутация: 353




robert пишет:
хм, теперь все намано, только превью не отображается Недовольство, огорчение
Вторая картинка..в сообщении.

Странно, не понял где там должно быть превью. Сейчас ещё раз проверил, вроде бы всё правильно работает
 
 
robert
Отправлено: 13 апреля 2009 — 18:28
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 258
Дата рег-ции: Март 2009  
Репутация: 8




error 404 - 2 картинка..вложил Улыбка
Прикреплено изображение
test2.JPG

 
 
mastersound
Отправлено: 13 апреля 2009 — 18:28
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 604
Дата рег-ции: Март 2009  
Откуда: Ё-бург
Репутация: 23




Сорри... слепой)))
 
 
yura3d
Отправлено: 13 апреля 2009 — 20:23
Post Id


Пользователь
ExBB Team
ExBB Developer
ExBB Mods Author


Покинул форум
Сообщений всего: 3394
Дата рег-ции: Февр. 2009  
Откуда: Минск, Беларусь
Репутация: 353




robert пишет:
error 404 - 2 картинка..вложил Улыбка

Да, сейчас посмотрел, действительно есть такая проблема. Для решения открываем файл printfile.php, находим строку:
CODE:
$width = 150;

И прямо под ней вставляем строку:
CODE:
$bigimgsrc = strtr($bigimgsrc, array(' ' => '%20'));
 
 
msnavigator
Отправлено: 8 мая 2011 — 23:25
Post Id



Пользователь
Junior Member


Покинул форум
Сообщений всего: 56
Дата рег-ции: Дек. 2009  
Откуда: Москва
Репутация: 6




Добрый вечер всем!
Заметил вот такую проблему (с публикацией изображений), ну чтобы не объяснять, привожу пример:

[img]http://album.foto.ru:8080/photos...1476/1240749.jpg[/img]
возможно ли как-то исправить, или обойти данную проблему? (удаление таких ссылок не предлагать Подмигивание )
Заранее спасибо всем, за помощь!
robert, пошу прощение за цитирование Закатив глазки .
 
 
Zeg
Отправлено: 9 мая 2011 — 00:07
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 891
Дата рег-ции: Март 2009  
Откуда: Беларусь
Репутация: 89




msnavigator, откройте файл include/fm.class.php, найдите строку

CODE:
$string = preg_replace_callback("#\[img\]\s*((http://|www\.)[A-Za-z0-9-_\./\?\%\&\+\;\,~=]+?)\s*\[/img\]#is",


и замените строкой

CODE:
$string = preg_replace_callback("#\[img\]\s*((http://|www\.)[А-Яа-яA-Za-z0-9-_\./\?\%\&\+\;\:\,~=]+?)\s*\[/img\]#is",


Это позволит использовать в именах файлов не только знак ":" для указания порта, но также буквы русского алфавита.

(Отредактировано автором: 9 мая 2011 — 00:08)

 
 
msnavigator
Отправлено: 9 мая 2011 — 12:47
Post Id



Пользователь
Junior Member


Покинул форум
Сообщений всего: 56
Дата рег-ции: Дек. 2009  
Откуда: Москва
Репутация: 6




Zeg
Спасибо, всё работает!!! Превосходно
 
 
Zeg
Отправлено: 9 мая 2011 — 16:16
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 891
Дата рег-ции: Март 2009  
Откуда: Беларусь
Репутация: 89




msnavigator, пожалуйста. Давно такое исправление сделал, т.к. надо было использовать картинки с разных Wiki. А там и кириллица и знаки препинания и всякие знаки.
 
 
BON
Отправлено: 31 июля 2011 — 14:21
Post Id



Администратор
ExBB Team
Admin


Покинул форум
Сообщений всего: 2762
Дата рег-ции: Нояб. 2010  
Откуда: СССР/Белгород
Репутация: 72




народ, а подскажите как сделать чтобы через теги img заработали и такие ссылки
CODE:
http://s58.photobucket.com/albums/g273/koresh23/?action=view&current=sosna1-1.jpg
http://s58.photobucket.com/albums/g273/koresh23/?action=view&current=13.jpg
http://s58.photobucket.com/albums/g273/koresh23/?action=view&current=sosna1-2.jpg


Вот они же только через теги картинок


 
 
Страниц (2): [1] 2 »
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0)
« Решение проблем »

> Похожие темы: Проблема с изображениями через теги [img]
Темы Форум Информация о теме Обновление
Аякс стрелочки
Проблема
Решение проблем Ответов: 2
Автор темы: Defenderyk
12 февраля 2009 — 19:53
Автор: yura3d
Не создаются категории и форум
Проблема с созданием категрии и форума в часнеости.
Решение проблем Ответов: 4
Автор темы: Kolyabis
16 июля 2015 — 18:23
Автор: electron
Добавляется точка с запятой (;) в конце текста и лишний пробел
если НЕ включить HTML теги в тексте сообщения
Решение проблем Ответов: 5
Автор темы: shyuser
21 июля 2009 — 22:15
Автор: yura3d
Неактивные ссылки
Проблема.
Общие вопросы Ответов: 45
Автор темы: Sasa1
3 мая 2012 — 15:07
Автор: BON
Мод: Регистрация и авторизация со сторонних ресурсов (Loginza)
Быстрая регистрация, вход на форум через социальные сети и другие популярные сайты
Модификации и дополнения Ответов: 300
Автор темы: Defenderyk
20 января 2015 — 10:31
Автор: variant0
 



Все гости форума могут просматривать этот раздел.
Только администраторы и модераторы могут создавать новые темы в этом разделе.
Только администраторы и модераторы могут отвечать на сообщения в этом разделе.
 




Яндекс.Метрика   

Powered by ExBB
ExBB FM 1.0 RC1 by TvoyWeb.ru
InvisionExBB Style converted by Markus®

[Script Execution time: 0.0842]     [ ]