ExBB Community ExBB Community
 Сайт проекта ExBB Общение объединяет!
Войдите на форум при помощиВойти через loginza
 Чат на форуме      Помощь      Поиск      Пользователи     BanList BanList


 Страниц (1): [1]   

> Описание: Если форум в папке forum сайта
Guyver
Отправлено: 19 февраля 2017 — 08:50
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




У меня есть сайт. У него своя иконка - чёрная.

На сайте в папке forum лежит форум - у него синяя иконка.

Захожу на форум - всё ОК. Иконка синяя. Но когда перехожу в админку - она становится чёрной. То же и с новыми сообщениями - если перейти по ссылке НОВЫЕ СООБЩЕНИЯ и их не будет - выведется сообщение

Цитата:
Сообщение!

Нет новых сообщений с последнего Вашего визита на форум


И при этом иконка опять становится чёрной, т.е. выводится не иконка форума, а иконка сайта. думаю, в других сообщениях будет выводиться тоже иконка сайта, а не форума.

Как это побороть? faviconforum.ico лежит в корне форума, а favicon.ico в корне сайта.

Пытался искать текст favicon во всех файлах форума - ничего не нашёл... В файле all_header.tpl ссылку на иконку заменил на верную ещё давным-давно. Но, как видно, это не во всех случаях помогает...

(Отредактировано автором: 19 февраля 2017 — 08:59)

 
 
electron
Отправлено: 24 февраля 2017 — 12:45
Post Id



Администратор
ExBB Team


Покинул форум
Сообщений всего: 3889
Дата рег-ции: Февр. 2009  
Репутация: 340




Guyver пишет:
faviconforum.ico лежит в корне форума

с таким названием фавикон может просто тупо не срабатывать
 
 
Guyver
Отправлено: 24 февраля 2017 — 13:32
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Ну... Он не срабатывает же не всегда, а только иногда. Значит, что-то где-то недописано просто...
 
 
electron
Отправлено: 25 февраля 2017 — 09:38
Post Id



Администратор
ExBB Team


Покинул форум
Сообщений всего: 3889
Дата рег-ции: Февр. 2009  
Репутация: 340




может кэш браузера мозг парит...
 
 
Vlad
Отправлено: 25 февраля 2017 — 11:17
Post Id


Пользователь
Newbie


Покинул форум
Сообщений всего: 9
Дата рег-ции: Янв. 2017  
Откуда: Россия
Репутация: 0




Guyver, в исходном коде страниц, где показываются неправильно иконки, посмотрите правильность путей к иконкам. Если этих ссылок нет, то может дописать их.
 
 
Guyver
Отправлено: 25 февраля 2017 — 11:39
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Так я же говорю - вообще задание иконки я нашёл только в одном файле - это all_header.tpl

Всё... Ничего другого я не нашёл. Имя иконки изначально было дефолтным и иконку я тупо заменил на свою. Проблема была изначально. Это уже потом я переобозвал иконку, чтобы не путать её с сайтной иконкой. Прблема никуда не исчезла и всё работает криво так же как и раньше.

Кэш не при чём - с любого компа так отображается. С телефона и т.д.

Получается, какая-то часть страниц форума выводится без условия задания иконки форума. Просто забыли прикрутить. И поэтому выводится иконка сайта по-умолчанию... Да? Это вся админка и мессаги типа

Цитата:
Редактирование сообщения

Сообщение успешно отредактированно!


Это потому, что ко всему этому (а может и к чему-то ещё) не прилинковано all_header.tpl, так? Надо же исправить? Проморгали это потому, что у вас сайт и форум - одна иконка. А у меня они разные! Может, как и у многих других...

П.С. Кстати - у вас ошибка, отредактированно с одной н же пишется, не?

(Отредактировано автором: 25 февраля 2017 — 11:59)

 
 
Guyver
Отправлено: 25 февраля 2017 — 12:30
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Чтобы не быть голословным:

Картинки (Отобразить)


1 - Мой форум. Иконка синяя.
2 - Сообщение форума. Иконка чёрная.
3 - Мой сайт. Иконка чёрная.
4 - Админка форума. Иконка чёрная.

2 и 4 - это неправильно!

(Отредактировано автором: 25 февраля 2017 — 12:38)

 
 
electron
Отправлено: 25 февраля 2017 — 15:42
Post Id



Администратор
ExBB Team


Покинул форум
Сообщений всего: 3889
Дата рег-ции: Февр. 2009  
Репутация: 340




Guyver пишет:
4 - Админка форума. Иконка чёрная.

пропишите
CODE:
<link rel="shortcut icon" href="favicon.ico">

в файле admin/all_header.tpl и будет фавикон светиться и там

Guyver пишет:
2 - Сообщение форума. Иконка чёрная.

зашел к вам на форум и потом по ссылке на чат. для гостей он естественно закрыт и светится синяя иконка. странно...

заглянем в функцию вывода подобных сообщений :
Спойлер (Отобразить)

как видно из этого кода , error.tpl , выводящий ошибки, плотно прикручен к шапке all_header.tpl , как на самом форуме, так и в админке. поэтому фавикон в ошибочных и сервисных сообщениях форума должен выводиться форумный
 
 
Guyver
Отправлено: 26 февраля 2017 — 01:16
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Спасибо! С админкой помогло!!! А вот с сообщениями нет. Видно что в коде страницы сообщений включена верная иконка, а выводится неверная. Может, браузер виноват? Не знаю...

(Отредактировано автором: 26 февраля 2017 — 01:30)

 
 
electron
Отправлено: 2 марта 2017 — 10:25
Post Id



Администратор
ExBB Team


Покинул форум
Сообщений всего: 3889
Дата рег-ции: Февр. 2009  
Репутация: 340




файл chief-net.ru/images/favicon.ico из папки images переместите в корень. фавикон форума переименуйте в favicon.ico , поправьте пути и названия в движках форума и сайта. у меня такое ощущение, что все-таки не нравится "кривое" название фавиконовского файла, который у вас присутствует на форуме
 
 
Guyver
Отправлено: 2 марта 2017 — 12:52
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Спс. Попробую...
 
 
Guyver
Отправлено: 2 января 2018 — 13:54
Post Id



Пользователь
Advanced Member


Покинул форум
Сообщений всего: 261
Дата рег-ции: Окт. 2014  
Откуда: Магадан
Репутация: 8




Попробовал - не помогло ничего. Так и выводятся разные иконки, увы...
 
 
Страниц (1): [1]
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0)
« Решение проблем »

> Похожие темы: Проблемы с иконкой форума
Темы Форум Информация о теме Обновление
Работа с файлом footer.tpl
Как дополнять выходные данные на странице форума
Решение проблем Ответов: 4
Автор темы: Павел Пушков
19 ноября 2017 — 14:23
Автор: Павел Пушков
Разрешенные расширения файлов для загрузки.
Загружается неразрешенное на форуме расширение файла изображения.
Решение проблем Ответов: 1
Автор темы: alexx
9 июля 2010 — 07:53
Автор: Александр Михалицын
Не считает темы и сообщения
После перемешения подфорумов в другой форум по статистике 0
Решение проблем Ответов: 4
Автор темы: shyuser
28 сентября 2010 — 20:34
Автор: yura3d
Не работает админпанель
Установил последнюю версию форума. Не работает админпанель
Решение проблем Ответов: 9
Автор темы: FlyRus
2 июня 2013 — 18:08
Автор: electron
Гугл сёрч
проблемы форума с индексированием
Решение проблем Ответов: 1
Автор темы: Guyver
13 января 2019 — 08:27
Автор: Guyver
 



Все гости форума могут просматривать этот раздел.
Только зарегистрированные пользователи могут создавать новые темы в этом разделе.
Только зарегистрированные пользователи могут отвечать на сообщения в этом разделе.
 




Яндекс.Метрика   

Powered by ExBB
ExBB FM 1.0 RC1 by TvoyWeb.ru
InvisionExBB Style converted by Markus®

[Script Execution time: 0.1712]     [ ]