ExBB Community ExBB Community
 Сайт проекта ExBB Общение объединяет!
Войдите на форум при помощиВойти через loginza
 Чат на форуме      Помощь      Поиск      Пользователи     BanList BanList


 Страниц (2): « 1 [2]   

> Без описания
1Bot
Отправлено: 11 сентября 2014 — 08:13
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 773
Дата рег-ции: Апр. 2009  
Откуда: Днепропетровск
Репутация: 69




гость
Проблема наверное в блокировании исходящих запросов от мода превью (функция getimagesize)

В файле include\lib.php заменяем функцию replace_img_link на следующий код:
CODE:

function replace_img_link($imlink) {
global $fm;
/*
Доработка мода превью-копий прикреплённых изображений
Автор CAB http://exbb.su/
*/
if (ini_get('allow_url_fopen')) { // проверяем разрешены ли удалённые соединения
$headersget = @get_headers ($imlink, 1); // запрос заголовков файла
if (preg_match("|200|", $headersget[0])) { // выделяем из ответа файл есть
if (($size = @getimagesize($imlink)) !== FALSE) { // запрос параметров изображения
if ($size[0] <= 512) { // сверяем ширину картинки с установленным числом
$imgtag = "<i> <img src=\"$imlink\" /></i>"; // выводим картинку без превью
} else {
if ($fm->exbb['redirect'] && !stristr($imlink, 'http://www.'.$fm->exbb_domain) && !stristr($imlink, 'http://'.$fm->exbb_domain)) // проверяем свой домен
$_imlink = 'rd2.php?'.$imlink; // редиректим чужой домен
else $_imlink = $imlink; // свой домен выводим без редиректа
$imgtag = $fm->LANG['ImgLinked']."<a href=\"$_imlink\" rel=\"clearbox\" title=\"".$fm->LANG['ToIncrease']."\" target=\"_blank\"><img src=\"printfile.php?action=link&img=$imlink\" border=\"0\" style=\"border: 1px outset #DCDCDC;\" /></a>"; // формируем код превью
}
} else {
$imgtag = "<i> <span class=\"admin\">&bull;&nbsp;</span>$imlink</i>"; // файл не изображение
}
} else {
$imgtag = "<i> <span class=\"admin\">&bull;&nbsp;</span>$imlink</i>"; // нет ответа что файл есть
}
} else {
$imgtag = "<i> <img src=\"$imlink\" /></i>"; // удалённые соединения не разрешены
}
return $imgtag;
}



Если не сработает, попробуйте убрать в приведенном коде все @ чтобы понять в чем причина.
 
 
гость
Отправлено: 11 сентября 2014 — 13:23
Post Id


Пользователь
Junior Member


Покинул форум
Сообщений всего: 51
Дата рег-ции: Окт. 2013  
Репутация: 0




1Bot пишет:
гость
Проблема наверное в блокировании исходящих запросов от мода превью (функция getimagesize)

В файле include\lib.php заменяем функцию replace_img_link на следующий код


После замены функции, никаких изменений не наблюдается.

1Bot пишет:

Если не сработает, попробуйте убрать в приведенном коде все @ чтобы понять в чем причина.


И при убранных "подавителях" никаких ошибок не всплыло, в еррор-логе все таже единтсвенная запись:

CODE:

[Thu Sep 11 20:08:51 2014] [error] [client 192.168.1.5] PHP Warning: implode() [<a href='function.implode'>function.implode</a>]: Invalid arguments passed in C:\\apache\\blablabla.ru\\www\\modules\\chat\\backend.php on line 206, referer: http://blablabla.ru/index.php



Поправка!!!

Выскочил таймаут:

CODE:

Warning: get_headers(http://exbb.info/community/im/emoticons/welcome.gif) [function.get-headers]: failed to open stream: Попытка установить соединение была безуспешной, т.к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера. in C:\apache\sorokovka.tomsk.ru\www\include\lib.php on line 408

Fatal error: Maximum execution time of 600 seconds exceeded in C:\apache\sorokovka.tomsk.ru\www\include\lib.php on line 408

(Отредактировано автором: 11 сентября 2014 — 13:29)

 
 
1Bot
Отправлено: 11 сентября 2014 — 13:41
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 773
Дата рег-ции: Апр. 2009  
Откуда: Днепропетровск
Репутация: 69




гость , копать нужно в сторону настроек сервера по пропуску исходящих запросов
 
 
гость
Отправлено: 11 сентября 2014 — 13:58
Post Id


Пользователь
Junior Member


Покинул форум
Сообщений всего: 51
Дата рег-ции: Окт. 2013  
Репутация: 0




Ругается на 408 строку, а там:

CODE:
$headersget = get_headers ($imlink, 1); // запрос заголовков файла
 
 
1Bot
Отправлено: 11 сентября 2014 — 14:11
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 773
Дата рег-ции: Апр. 2009  
Откуда: Днепропетровск
Репутация: 69




гость пишет:
Ругается на 408 строку, а там:

CODE:
$headersget = get_headers ($imlink, 1); // запрос заголовков файла


Это понятно.
Firewall блокирует исходящие запросы.
 
 
гость
Отправлено: 11 сентября 2014 — 14:50
Post Id


Пользователь
Junior Member


Покинул форум
Сообщений всего: 51
Дата рег-ции: Окт. 2013  
Репутация: 0




1Bot пишет:
Firewall блокирует исходящие запросы.


Белый флаг

Это была шутка или я чего то не понимаю???

Все модули работают и картинки отображаются, а запросы именно модуля "превью" режутся Firewall-ом.

Разве не все веб-запросы идут по 80-му (и еже с ним) порту? Или имеется какой то иной Firewall (типа встроенного в апач модуля)??? А?!
 
 
1Bot
Отправлено: 12 сентября 2014 — 06:42
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 773
Дата рег-ции: Апр. 2009  
Откуда: Днепропетровск
Репутация: 69




гость пишет:
1Bot пишет:
Firewall блокирует исходящие запросы.


Белый флаг

Это была шутка или я чего то не понимаю???

Все модули работают и картинки отображаются, а запросы именно модуля "превью" режутся Firewall-ом.

Разве не все веб-запросы идут по 80-му (и еже с ним) порту? Или имеется какой то иной Firewall (типа встроенного в апач модуля)??? А?!

Что тут удивительного? Браузеру разрешено, а серверу apache нет.
 
 
гость
Отправлено: 18 сентября 2014 — 16:06
Post Id


Пользователь
Junior Member


Покинул форум
Сообщений всего: 51
Дата рег-ции: Окт. 2013  
Репутация: 0




Всем огромное спасибо за помощь, особенно неотразимой 1Bot! Закатив глазки


Проблема решена, дело действительно было в блокировке трафика инициированного Апачем.

С Уважением,
Гость

P.S. Своевременным благодарностям помешала банальная простуда.
 
 
1Bot
Отправлено: 24 сентября 2014 — 17:47
Post Id



Пользователь
Super Member


Покинул форум
Сообщений всего: 773
Дата рег-ции: Апр. 2009  
Откуда: Днепропетровск
Репутация: 69




гость выздоравливайте Улыбка
 
 
Страниц (2): « 1 [2]
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0)
« Решение проблем »

> Похожие темы: Проблема с ExBBCode [img]
Темы Форум Информация о теме Обновление
Аякс стрелочки
Проблема
Решение проблем Ответов: 2
Автор темы: Defenderyk
12 февраля 2009 — 19:53
Автор: yura3d
Перенаправление на rel= с разела "объявления"
Проблема с переходом
Решение проблем Ответов: 2
Автор темы: mastersound
31 мая 2011 — 21:19
Автор: mastersound
Неактивные ссылки
Проблема.
Общие вопросы Ответов: 45
Автор темы: Sasa1
3 мая 2012 — 15:07
Автор: BON
Модератор в ExBBDarkGrey Style v1.0.10
Проблема
Решение проблем Ответов: 4
Автор темы: Marlboro
3 марта 2012 — 17:17
Автор: altjo
Не создаются категории и форум
Проблема с созданием категрии и форума в часнеости.
Решение проблем Ответов: 4
Автор темы: Kolyabis
16 июля 2015 — 18:23
Автор: electron
 



Все гости форума могут просматривать этот раздел.
Только администраторы и модераторы могут создавать новые темы в этом разделе.
Только администраторы и модераторы могут отвечать на сообщения в этом разделе.
 




Яндекс.Метрика   

Powered by ExBB
ExBB FM 1.0 RC1 by TvoyWeb.ru
InvisionExBB Style converted by Markus®

[Script Execution time: 0.0636]     [ ]